Saturday, October 13, 2007

iPhone Safari Browser Web Links not working...

came across this post in the apple web support discussion forums and it worked:

Re: Safari - links not opening when clicked
Posted: Oct 2, 2007 8:09 AM in response to: Ashley Gwozdz Reply Email


A friend of mine bought a new iPhone yesterday and came to me with this issue a little while ago. I've never experienced this myself, but I suggested that he reset the application by holding the home button for six seconds. For him, this reset of Safari solved his problem.

17 comments:

Anonymous said...

Awesome. I've been having problems with my Safari links not working and this solved the issue. Your post is much appreciated as I couldn't find a fix anywhere else on the web.

CWI Media & Marketing said...

Worked like a champ! I just got an iPhone last week and yesterday, Safari stopped working in portrait mode, but some features would work in landscape mode. However, I wasn't able to access any of the links in either mode. I Googled the problem and found your site and holding the Home button down for six seconds while in Safari reset it and everything is back to normal. Thanks!

Sean said...

YES! Thanks.

Anonymous said...

YeS!!!]
Thanks!!
i thought i had to go the the shop!

Neil said...

Nice one. One of best posts ever woot. No need to reset - again!

Anonymous said...

Thank you so much - I've been sitting here for the past hour thinking I've broken my brand new iphone

Anonymous said...

Thank you!

chris said...

Thankyou so much! my iphone 3G wouldn'nt load any webpage even google it just stayed at untitled but i tried this and it worked! thanks so much!

Anonymous said...

That does not help me, the bookmarks menu is up, so I cannot see the home button.

Anonymous said...

home button is the hardware button, not a button on the touchscreen but the black button with the square on it in the bottom, middle of the phone.

Anonymous said...

7-18-09. Me too! New iphone 3gs user. Safari stop working...but the 6 second holding of the home key button worked first time. Note, it brings up "Voice Control", but I kept holding the button. Then, went to Safari and...ALL GOOD. Love it when a fix works.

Thanks very much.

philipp said...

Worked worked worked! Thanks so much *Gies love*

philipp said...
This comment has been removed by the author.
Max said...

Thanks so much!!! worked a treat!! i was almost fretting to the fact of thinking of replacing the phone. once again thank you!

Stuti said...

Thanks a lot :) Worked for me too.

Anonymous said...

Sounds great, but where on earth is the "home button"?

Anonymous said...

Found the description of the home button, thank you, "anonymous", but holding this for 6 seconds did not solve my problem. Links work fine on my laptop, but not my iPhone